|  Start
Hilfe

Hosting für Linux (cPanel) Hilfe

Entschuldigung, diese Seite wurde von einem Sprachroboter übersetzt.
Unsere Übersetzer arbeiten fleißig, aber diese Seite wartet noch darauf, fachkundig ins Deutsche übertragen zu werden. Bis dahin ist unser Roboter aktiv. Für sprachliche Mängel bitten wir um Entschuldigung. Teile uns gerne mit den Buttons unten mit, ob dir diese Seite trotzdem helfen konnte. Zur englischen Version wechseln! Machen die Roboter ihre Sache gut? Mit den Schaltflächen unten auf der Seite können Sie uns das mitteilen. Zur englischen Version wechseln

Ändern Sie die Datei Erweiterung Handler/Sprachen (Linux)

Ihr Linux-Webhosting-Konto können verarbeiten Sie Dateien in Sprachen. Datei-Erweiterungen ermitteln Ihres Kontos Standard-Verhalten. Z. B. verarbeitet Ihr Konto Dateien in .html als statischer HTML-Code und Ihres Kontos Standard verarbeitet PHP-Version Dateien, die endet mit .php.

Apache Handler, aktualisieren Sie Ihre .htaccess Datei ändern Ihres Kontos Standard-Datei Erweiterungsverhalten, oder Sie können benutzerdefinierte Datei Erweiterungen hinzufügen.

Finden Sie in der folgenden Tabelle standardmäßig dynamische Sprachen.

Erweiterung Handler Version
.php X-Httpd-php Standard-PHP-version
.php5 X-Httpd-php5-3 PHP 5.3
.pl, .rb,
.py, .cgi
CGI-Skript Sprache abhängigen
.fcgi, .fpy,
.fpl
Fcgid-Skript Sprache abhängigen


Warnung: Das Standardverhalten der Datei-Erweiterungen in Ihr hosting-Konto ändern kann unerwarteter Ergebnisse liefern, möglichst deaktivieren Software installiert. Diese erweiterte Einstellung ist nur für erfahrene Benutzer vorgesehen.

Einige Erweiterungen benötigen übergreifende scripting-Sprache-spezifisch Vorbereitung (z. B. Skripts für die Verwendung per CGI oder FastCGI), die in diesem Artikel nicht behandelt.

Standard-Datei Erweiterungen ändern

Sie können Ihres Kontos Standard Datei Erweiterungsverhalten ändern, indem Sie aktualisieren Ihre .htaccess die Datei mit einem Handler.

Beispielsweise, wenn Sie Ihre PHP-Version Erweiterung wird geöffnet. .php, und Sie ändern möchten. PHP 5.3, fügen Sie den folgenden Code in Ihrem hosting-Konto .htaccess Datei:

AddHandler x-httpd-php5-3 .php

Ebenso, wenn Sie, FastCGI alle Dateien mit der Erweiterung verarbeitet möchten .pl, fügen Sie den folgenden Code in Ihrem hosting-Konto .htacess Datei:

AddHandler fcgid-script .pl


Erstellen benutzerdefinierter Datei Extensions

Sie können auch benutzerdefinierte Datei Erweiterungen erstellen, indem Sie Ihr hosting-Konto aktualisieren .htaccess die Datei mit einem Handler.

Wenn Sie den folgenden Code zum Hinzufügen, z. B. Ihre .htaccess Datei, PHP 5.3 kann die benutzerdefinierte Erweiterung verarbeitet. .mysite:

Options +ExecCGI
AddHandler x-httpd-php5-3 .mysite

FastCGI deaktivieren

Sie können mit dieser Methode einschließlich in die folgenden FastCGI deaktivieren Ihrer .htaccess Datei:

Options +ExecCGI
addhandler x-httpd-php5-cgi .php

Sie können nicht FastCGI mit unserer cPanel shared-hosting-Konten (deaktivierenWeitere Informationen) oder Web/Klassisch Firmen PHP-Versionen 5.3 oder höher)Weitere Informationen).

Klicken Sie hier Weitere Informationen über Apache Handler.


War dieser Artikel hilfreich?
Vielen Dank für deine Vorschläge. Um mit einem Mitarbeiter unsere Kundenservice zu sprechen, nutze bitte die Telefonnummer des Support oder die Chat-Option oben.
Gern geschehen! Können wir sonst noch etwas für Sie tun?
Tut uns leid. Teile uns mit, was unklar war, und warum diese Lösung nicht zur Behebung des Problems geführt hat.